• Uncaught DOMException: Failed to execute ‘btoa’ on ‘Window’

    在使用js btoa 编码为base64的时候 报错提示 Uncaught DOMException: Failed to execute 'btoa' on 'Window': The string to be encoded contains characters outside of the Latin1 range. 只有含有中文的时候才会报错,如果是英文和数字的话就不会有错误 这个问题前…

    Learn 2020-09-28 155

  • lnmp配置laravel

    可参考这篇文章与thinkphp配置基本一致:https://www.blyoo.com/4202.html 除了第一步需要改成laravel include rewrite/laravel.conf; 后续基本一致

    Learn 2020-09-21 160

  • phpstorm postcss-cli autoprefixer Input Error: You must pass a valid list of files to parse

    phpstorm或者webstorm配置autoprefixer的教程,百度即可 开始吹牛逼 使用postcss+autoprefixer压缩文件时候,提示: Input Error: You must pass a valid list of files to parse 查看postcss和autoprefixer代码也没看出个所以然, 网上查也查不到, 去年我就配置过一次了,但是去年没遇到任…

    Learn 2020-09-21 231

  • Plugin Error: Cannot find module ‘postcss’

    使用postcss+autoprefixer压缩css文件时候,却一直报这个错: Plugin Error: Cannot find module 'postcss' Require stack: - C:\Users\admin\AppData\Roaming\npm\node_modules\autoprefixer\lib\utils.js - C:\Users\admin\AppData\…

    Learn 2020-09-21 206

  • npm 升级

    npm 升级 npm升级准确来说应该是重新安装一遍,默认安装最新版本 npm install -g npm npm升级到指定版本 比如升级到1.2.3 换句话说,就是重新安装一下,然后安装到指定的版本 npm install -g npm@1.2.3 参考: https://www.cnblogs.com/looyulong/p/9835955.html

    Learn 2020-09-20 132

  • TX客服真是个傻哈皮,你瞎吗,答非所问

    由于问题选项,并没有与注销相关的,我就随便选了一个问题咨询 我描述的这么清楚,你封你奶奶个腿的号

    Archives 2020-08-07 306

  • wordpress添加自定义文章状态和获取调用文章状态

    前言 我有个企业网站,一个简单商品展示型的那种网站,我想删除商品,但是还想让他不显示404页面,玩wordpress的都知道,文章只有发布出去,才会显示出来, 我想让他像京东那类电商网站一样,商品直接显示已经下架, 于是就在想,如果能给文章添加个自定义的状态,我可以通过文章状态来判断后续, 注册文章状态 下架 // 注册新的文章状态 add_action('init', function () {…

    WordPress 2020-07-30 339

  • win7 MSVCP140.dll丢失

    MSVCP140.dll缺失的原因是因为缺少vs2015的运行库, 下载Microsoft Visual C++ 2015运行库即可 单独下载 Visual C++2015 Visual C++ Redistributable for Visual Studio 2015 https://www.microsoft.com/zh-CN/download/details.aspx?id=48145 …

    Archives 2020-07-26 376

  • Photoshop CC 2018 老卡在正在读取首选项界面

    因为我的系统是win10 1607,不能安装Photoshop 2018以上的版本, 于是就安装了Photoshop 2018版本的, 但是经常性的,用不了,老卡在,正在读取首选项, 我已经把Photoshop 2018的卸载了,安装了Photoshop 2017的,用Photoshop 2017截的图,反正就是卡在这个界面 即使偶尔,没卡在正在读取首选项,,但是进入了也会卡住,动不了 每次我都是…

    Archives 2020-07-23 456

  • laravel LogicException Please make sure the PHP Redis extension is installed and enabled

    首先先确定,laravel redis配置均为正确且redis也已安装的时候 还是提示这个错误Please make sure the PHP Redis extension is installed and enabled 那么看看一看php redis拓展是不是没打开 以我win10 phpstudy为例 环境>php>设置 拓展组件>把redis打开 或者 网站>管理>php拓展>找到red…

    Learn 2020-05-18 1645

  • 逛淘宝真的跟逛窑子似的

    我也是被封面图吸引进去的,哈哈哈 1000多万的访问量 评论笑死人

    Archives 2020-05-14 2184

  • Let’s Encrypt 创建或更新证书提示 It seems the CA server is busy now

    首先我的环境是lnmp lnmp add ssl 创建证书时候,提示这个 先测试一下,看看是不是scme.sh需要升级的缘故 执行一下acme.sh升级 /usr/local/acme.sh/acme.sh --upgrade 升级成功 再次创建证书,ok,成功了 其实另一个问题也会导致提示这个错误,之前我也遇到过,就是如果使用thinkPHP或者laravel这类框架的话,因为网站路径问题,同样…

    Learn 2020-04-27 1072

  • laravel ajax post请求携带csrf token

    jquery 写法 $.ajaxSetup({ headers: { 'X-XSRF-TOKEN': getCookie('XSRF-TOKEN') } }); //下面执行post请求 $.post() 封装一个取cookie函数 这个我经常使用,每次用到了就去w3school复制一下 function getCookie(cname) { var name = cname + "="; var…

    Learn 2020-03-27 1111

  • linux lftp command not found

    Install centos yum install lftp 如果提示:-bash: :yum: command not found 看:https://www.blyoo.com/3975.html debian/ubuntu apt-get install lftp

    Learn 2020-03-27 950

  • js 判断是否为IE浏览器

    条件注释,不适用于IE10及以上版本,无效果 所以只能使用js判断 适用于所有大于ie 6版本的浏览器(IE7、8、9、10等),包括Edge浏览器 参考: https://stackoverflow.com/questions/13785587/if-ie-not-working https://www.cnblogs.com/garfieldzhong/p/5815187.html

    Learn 2020-03-26 739