phpstorm不能更改php language level

由于重装了系统,全部格式了,也安装了最新版的phpstorm

但是打开以前php文件,尴尬了,好多波浪线,因为版本低,

于是就去改高一点的php版本,

但是最尴尬的是,无法选择,

如何解决呢

点击composer>Synchronize IDE Settings with composer.json前面的勾去掉,然后apply,再回去就可以选择php版本了